Eclipse 3.6.1 (Helios) & Subversive: Installing SVN connector failed

I tried to set up the Subversive plugin on a fresh Eclipse 3.6.1 (Helios) installation recently. I used the Subversive version 0.7.9I20100512-1900 from the Helios repository, but trying to install a SVN Kit connector (I tried SVN Kit 1.3.2) failed with the following error message:

“Cannot complete installation: Problems occurred while performing installation: Operation details
See error log for details.”

In the error log, I found the following Exception:

!ENTRY org.eclipse.team.svn.core.svnnature 4 0 2011-01-10 22:56:20.458
!MESSAGE Problems occurred while performing installation: Operation details
!STACK 1
org.eclipse.core.runtime.CoreException: Operation details
	at org.eclipse.team.svn.ui.discovery.PrepareInstallProfileJob_3_6.resolve(PrepareInstallProfileJob_3_6.java:129)
	at org.eclipse.team.svn.ui.discovery.PrepareInstallProfileJob_3_6.run(PrepareInstallProfileJob_3_6.java:97)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
Contains: Cannot complete the install because one or more required items could not be found.
Contains: Software being installed: SVNKit 1.3.3 Implementation (Optional) 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.svnkit16.feature.group 2.2.2.I20101203-1700)
Contains: Missing requirement: SVNKit 1.3.3 Implementation (Optional) 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.svnkit16.feature.group 2.2.2.I20101203-1700) requires 'org.eclipse.team.svn.feature.group [0.7.9.I20101001-1700,1.0.0)' but it could not be found
!SUBENTRY 1 org.eclipse.equinox.p2.operations 4 0 2011-01-10 22:56:20.476
!MESSAGE Operation details
!SUBENTRY 2 org.eclipse.equinox.p2.director 4 1 2011-01-10 22:56:20.476
!MESSAGE Cannot complete the install because one or more required items could not be found.
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-01-10 22:56:20.476
!MESSAGE Software being installed: SVNKit 1.3.3 Implementation (Optional) 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.svnkit16.feature.group 2.2.2.I20101203-1700)
!SUBENTRY 3 org.eclipse.equinox.p2.director 4 0 2011-01-10 22:56:20.476
!MESSAGE Missing requirement: SVNKit 1.3.3 Implementation (Optional) 2.2.2.I20101203-1700 (org.polarion.eclipse.team.svn.connector.svnkit16.feature.group 2.2.2.I20101203-1700) requires 'org.eclipse.team.svn.feature.group [0.7.9.I20101001-1700,1.0.0)' but it could not be found

After some research I found out, that this problem is well-known and as stated in the Subversive’s FAQ section uncorrectable for the Subversive version included in the Helios repository:

I could not install connectors after installing plug-in from the Helios repository. What should I do?
There was an issue with update sites layout for “release” versions, meaning that a different releases had references to the same connectors update site location. So, we have decided to correct this issue, so that there will be no problems with the future releases. Unfortunately there is no way to fix the Helios repository at this stage and the right way to avoid the issue is to install the latest plug-in version from the “Early access” update site. It is not the realease but development build, but it still stable and better because it contains a lot of fixes for a different issues.

To fix the problem use the Subversive update site http://download.eclipse.org/technology/subversive/0.7/update-site/ to update the Subversive plugin (today 0.7.9.I20101203-1700 is the latest version). After restarting Eclipse the SVN connector selection and installation should work as expected.

Comments

  1. Gabe

    I’ve been trying to figure this out forever. Thanks for the information on this! It’s greatly appreciated!

  2. IcyT

    Thank you very much. This finally helped us after several times of un- and reinstalling subversive.

  3. aya

    Hi! I’ve been trying to figure this problem out for over an hour now, and I’m lost. Thank you so much for this information! 🙂

  4. Lars

    Thanks as well!

  5. Cricket La Chica

    Man, you are a life saver! Thanks a lot Jan Jonas! I’m using Aptana Studio 3 beta, and it’s using Helios I believe. I couldn’t figure out how to install Subversive properly as it was giving me errors while trying to install the connectors. I didn’t think about going to the FAQ’s section of Subversive — I just Googled the error itself, and it brought me here!

    Thanks for quoting that error message, a lot of people just Google that, haha.

  6. Wizo

    Hey! I tried to use your suggestion to install the whole Subversive in Eclipse Helios. However, I can’t access my googlecode project through HTTPS. But I success in check out my project through HTTP, which is unable to commit!
    And I also try to use TortoiseSVN to access my project through HTTPS and HTTP. Both can be accessed successfully.

    Do you know what’s wrong? It did drive me crazy these days!

    PS:This is the error report when I try to build a new repository location via HTTPS URL
    Checkout operation for ‘https://wizo-csb.googlecode.com/svn’ failed.
    svn: Connection reset
    svn: PROPFIND request failed on ‘/svn’

    Thanks!

  7. Jan Jonas

    Hi Wizo, are you able to commit using TortoiseSVN and the HTTPS repository location?

  8. smiley

    Thanks a lot!! You are the best-super svn helper i have seen!!!

Leave a comment

Your email address will not be published. Required fields are marked *

*